import Foundation
let pattern = #"^https?:\/\/(.*addons|au[0-9])\.mozilla\.(org|net|com)\.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://addons.mozilla.org/en-US/firefox/themes
https://addons.mozilla.org/en-US/firefox/addons/buttons.js?b=ea33612-5654d042
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)