import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/(.*addons|au[0-9])\\.mozilla\\.(org|net|com)\\.*";
final String string = "https://addons.mozilla.org/en-US/firefox/themes\n"
+ "https://addons.mozilla.org/en-US/firefox/addons/buttons.js?b=ea33612-5654d042";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}