using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/(.*addons|au[0-9])\.mozilla\.(org|net|com)\.*";
string input = @"https://addons.mozilla.org/en-US/firefox/themes
https://addons.mozilla.org/en-US/firefox/addons/buttons.js?b=ea33612-5654d042";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}