re = /^https?:\/\/(.*addons|au[0-9])\.mozilla\.(org|net|com)\.*/
str = 'https://addons.mozilla.org/en-US/firefox/themes
https://addons.mozilla.org/en-US/firefox/addons/buttons.js?b=ea33612-5654d042'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end