const regex = /^https?:\/\/(.*addons|au[0-9])\.mozilla\.(org|net|com)\.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/(.*addons|au[0-9])\\.mozilla\\.(org|net|com)\\.*', 'g')
const str = `https://addons.mozilla.org/en-US/firefox/themes
https://addons.mozilla.org/en-US/firefox/addons/buttons.js?b=ea33612-5654d042`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}