$re = '/^https?:\/\/(.*addons|au[0-9])\.mozilla\.(org|net|com)\.*/';
$str = 'https://addons.mozilla.org/en-US/firefox/themes
https://addons.mozilla.org/en-US/firefox/addons/buttons.js?b=ea33612-5654d042';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);