#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^https?:\/\/(.*addons|au[0-9])\.mozilla\.(org|net|com)\.*"
Local $sString = "https://addons.mozilla.org/en-US/firefox/themes" & @CRLF & _
"https://addons.mozilla.org/en-US/firefox/addons/buttons.js?b=ea33612-5654d042"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")