package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^https?:\/\/(.*addons|au[0-9])\.mozilla\.(org|net|com)\.*`)
var str = `https://addons.mozilla.org/en-US/firefox/themes
https://addons.mozilla.org/en-US/firefox/addons/buttons.js?b=ea33612-5654d042`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}