import Foundation
let pattern = ##"\{\{(?:\s*)((?:#|\^|\/|>|&|=|!)?)(.*?)(?:\s*)\}\}"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
Dieser Content stammt aus dem Subtemplate CIS-SUB-2xxx
Lokale Variablen haben im Subtemplate einen andern Wert
{{#L_IP_ADDRESSES_2}}
{{ .}}
{{ /L_IP_ADDRESSES_2 }}
{{=<$ $>=}}
Externe Variablen haben den gleichen Wert und werden nur einmal abgerufen:
{{E_RFC4}}
Noch ein Subtemplate im Subtemplate
{{>CIS-SUB-COMMON@1.0.0}}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)