# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{\{(?:\s*)((?:#|\^|\/|>|&|=|!)?)(.*?)(?:\s*)\}\}"
test_str = ("Dieser Content stammt aus dem Subtemplate CIS-SUB-2xxx\n\n"
"Lokale Variablen haben im Subtemplate einen andern Wert\n"
"{{#L_IP_ADDRESSES_2}}\n"
" {{ .}}\n"
"{{ /L_IP_ADDRESSES_2 }}\n\n\n"
"{{=<$ $>=}}\n"
"Externe Variablen haben den gleichen Wert und werden nur einmal abgerufen:\n\n"
"{{E_RFC4}}\n\n\n"
"Noch ein Subtemplate im Subtemplate\n"
"{{>CIS-SUB-COMMON@1.0.0}}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.