#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{\{(?:\s*)((?:#|\^|\/|>|&|=|!)?)(.*?)(?:\s*)\}\}"
Local $sString = "Dieser Content stammt aus dem Subtemplate CIS-SUB-2xxx" & @CRLF & _
"" & @CRLF & _
"Lokale Variablen haben im Subtemplate einen andern Wert" & @CRLF & _
"{{#L_IP_ADDRESSES_2}}" & @CRLF & _
" {{ .}}" & @CRLF & _
"{{ /L_IP_ADDRESSES_2 }}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{{=<$ $>=}}" & @CRLF & _
"Externe Variablen haben den gleichen Wert und werden nur einmal abgerufen:" & @CRLF & _
"" & @CRLF & _
"{{E_RFC4}}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Noch ein Subtemplate im Subtemplate" & @CRLF & _
"{{>CIS-SUB-COMMON@1.0.0}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")