package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{\{(?:\s*)((?:#|\^|\/|>|&|=|!)?)(.*?)(?:\s*)\}\}`)
var str = `Dieser Content stammt aus dem Subtemplate CIS-SUB-2xxx
Lokale Variablen haben im Subtemplate einen andern Wert
{{#L_IP_ADDRESSES_2}}
{{ .}}
{{ /L_IP_ADDRESSES_2 }}
{{=<$ $>=}}
Externe Variablen haben den gleichen Wert und werden nur einmal abgerufen:
{{E_RFC4}}
Noch ein Subtemplate im Subtemplate
{{>CIS-SUB-COMMON@1.0.0}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}