using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{(?:\s*)((?:#|\^|\/|>|&|=|!)?)(.*?)(?:\s*)\}\}";
string input = @"Dieser Content stammt aus dem Subtemplate CIS-SUB-2xxx
Lokale Variablen haben im Subtemplate einen andern Wert
{{#L_IP_ADDRESSES_2}}
{{ .}}
{{ /L_IP_ADDRESSES_2 }}
{{=<$ $>=}}
Externe Variablen haben den gleichen Wert und werden nur einmal abgerufen:
{{E_RFC4}}
Noch ein Subtemplate im Subtemplate
{{>CIS-SUB-COMMON@1.0.0}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}