$re = '/\{\{(?:\s*)((?:#|\^|\/|>|&|=|!)?)(.*?)(?:\s*)\}\}/';
$str = 'Dieser Content stammt aus dem Subtemplate CIS-SUB-2xxx
Lokale Variablen haben im Subtemplate einen andern Wert
{{#L_IP_ADDRESSES_2}}
{{ .}}
{{ /L_IP_ADDRESSES_2 }}
{{=<$ $>=}}
Externe Variablen haben den gleichen Wert und werden nur einmal abgerufen:
{{E_RFC4}}
Noch ein Subtemplate im Subtemplate
{{>CIS-SUB-COMMON@1.0.0}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);