import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{(?:\\s*)((?:#|\\^|\\/|>|&|=|!)?)(.*?)(?:\\s*)\\}\\}";
final String string = "Dieser Content stammt aus dem Subtemplate CIS-SUB-2xxx\n\n"
+ "Lokale Variablen haben im Subtemplate einen andern Wert\n"
+ "{{#L_IP_ADDRESSES_2}}\n"
+ " {{ .}}\n"
+ "{{ /L_IP_ADDRESSES_2 }}\n\n\n"
+ "{{=<$ $>=}}\n"
+ "Externe Variablen haben den gleichen Wert und werden nur einmal abgerufen:\n\n"
+ "{{E_RFC4}}\n\n\n"
+ "Noch ein Subtemplate im Subtemplate\n"
+ "{{>CIS-SUB-COMMON@1.0.0}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}