const regex = /\{\{(?:\s*)((?:#|\^|\/|>|&|=|!)?)(.*?)(?:\s*)\}\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{(?:\\s*)((?:#|\\^|\\\/|>|&|=|!)?)(.*?)(?:\\s*)\\}\\}', 'g')
const str = `Dieser Content stammt aus dem Subtemplate CIS-SUB-2xxx
Lokale Variablen haben im Subtemplate einen andern Wert
{{#L_IP_ADDRESSES_2}}
{{ .}}
{{ /L_IP_ADDRESSES_2 }}
{{=<\$ \$>=}}
Externe Variablen haben den gleichen Wert und werden nur einmal abgerufen:
{{E_RFC4}}
Noch ein Subtemplate im Subtemplate
{{>CIS-SUB-COMMON@1.0.0}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}