import Foundation
let pattern = #"([A-z_$][\w$]*)\s+as\s+([A-z_$][\w$]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
const { export1 as alias1 } = require("module-name");
const { export2 as alias2, export3 as alias3 } = require("module-name");
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1: $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)