use strict;
my $str = 'const { export1 as alias1 } = require("module-name");
const { export2 as alias2, export3 as alias3 } = require("module-name");';
my $regex = qr/([A-z_$][\w$]*)\s+as\s+([A-z_$][\w$]*)/p;
my $subst = '$1: $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";