const regex = /([A-z_$][\w$]*)\s+as\s+([A-z_$][\w$]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-z_$][\\w$]*)\\s+as\\s+([A-z_$][\\w$]*)', 'g')
const str = `const { export1 as alias1 } = require("module-name");
const { export2 as alias2, export3 as alias3 } = require("module-name");`;
const subst = `$1: $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);