// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-z_$][\w$]*)\s+as\s+([A-z_$][\w$]*)").unwrap();
let string = "const { export1 as alias1 } = require(\"module-name\");
const { export2 as alias2, export3 as alias3 } = require(\"module-name\");";
let substitution = "$1: $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}