using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-z_$][\w$]*)\s+as\s+([A-z_$][\w$]*)";
string substitution = @"$1: $2";
string input = @"const { export1 as alias1 } = require(""module-name"");
const { export2 as alias2, export3 as alias3 } = require(""module-name"");";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}