# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([A-z_$][\w$]*)\s+as\s+([A-z_$][\w$]*)"
test_str = ("const { export1 as alias1 } = require(\"module-name\");\n"
"const { export2 as alias2, export3 as alias3 } = require(\"module-name\");")
subst = "$1: $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.