import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-z_$][\\w$]*)\\s+as\\s+([A-z_$][\\w$]*)";
final String string = "const { export1 as alias1 } = require(\"module-name\");\n"
+ "const { export2 as alias2, export3 as alias3 } = require(\"module-name\");";
final String subst = "$1: $2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}