# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-z_$][\w$]*)\s+as\s+([A-z_$][\w$]*)/$1: $2/g;t' <<< "const { export1 as alias1 } = require(\"module-name\");
const { export2 as alias2, export3 as alias3 } = require(\"module-name\");"