import Foundation
let pattern = #"([+-]?(?:(?:\d+\.?\d*\*?[xX]\^\d+)|(?:\d+\.?\d*\*?[xX])|(?:[xX]\^\d+)|(?:[xX])|(?:\d+\.?\d*)))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
-5.0x^5 + 20x^4 +x^3 + x +2
5*x^4 + 2.5*x + 3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)