re = /([+-]?(?:(?:\d+\.?\d*\*?[xX]\^\d+)|(?:\d+\.?\d*\*?[xX])|(?:[xX]\^\d+)|(?:[xX])|(?:\d+\.?\d*)))/
str = '-5.0x^5 + 20x^4 +x^3 + x +2
5*x^4 + 2.5*x + 3'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result