import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([+-]?(?:(?:\\d+\\.?\\d*\\*?[xX]\\^\\d+)|(?:\\d+\\.?\\d*\\*?[xX])|(?:[xX]\\^\\d+)|(?:[xX])|(?:\\d+\\.?\\d*)))";
final String string = "-5.0x^5 + 20x^4 +x^3 + x +2\n"
+ "5*x^4 + 2.5*x + 3";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}