#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([+-]?(?:(?:\d+\.?\d*\*?[xX]\^\d+)|(?:\d+\.?\d*\*?[xX])|(?:[xX]\^\d+)|(?:[xX])|(?:\d+\.?\d*)))"
Local $sString = "-5.0x^5 + 20x^4 +x^3 + x +2" & @CRLF & _
"5*x^4 + 2.5*x + 3"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)