use strict;
my $str = '-5.0x^5 + 20x^4 +x^3 + x +2
5*x^4 + 2.5*x + 3';
my $regex = qr/([+-]?(?:(?:\d+\.?\d*\*?[xX]\^\d+)|(?:\d+\.?\d*\*?[xX])|(?:[xX]\^\d+)|(?:[xX])|(?:\d+\.?\d*)))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";