// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([+-]?(?:(?:\d+\.?\d*\*?[xX]\^\d+)|(?:\d+\.?\d*\*?[xX])|(?:[xX]\^\d+)|(?:[xX])|(?:\d+\.?\d*)))").unwrap();
let string = "-5.0x^5 + 20x^4 +x^3 + x +2
5*x^4 + 2.5*x + 3";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}