using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+-]?(?:(?:\d+\.?\d*\*?[xX]\^\d+)|(?:\d+\.?\d*\*?[xX])|(?:[xX]\^\d+)|(?:[xX])|(?:\d+\.?\d*)))";
string substitution = @"";
string input = @"-5.0x^5 + 20x^4 +x^3 + x +2
5*x^4 + 2.5*x + 3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}