import Foundation
let pattern = #"(?i)(EDIResources\/EDITradingPartnerUpdates\.aspx)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/editradingpartnerupdates.aspx
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?gclid=jjj
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"resources/edi-tips$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)