package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?i)(EDIResources\/EDITradingPartnerUpdates\.aspx)(.*)`)
var str = `www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/editradingpartnerupdates.aspx
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?gclid=jjj`
var substitution = "resources/edi-tips$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}