#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?i)(EDIResources\/EDITradingPartnerUpdates\.aspx)(.*)"
Local $sString = "www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123" & @CRLF & _
"www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123&gclid=jjj" & @CRLF & _
"www.1edisource.com/ediresources/editradingpartnerupdates.aspx" & @CRLF & _
"www.1edisource.com/ediresources/editradingpartnerupdates.aspx?gclid=jjj"
Local $sSubst = "resources/edi-tips$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)