$re = '/(?i)(EDIResources\/EDITradingPartnerUpdates\.aspx)(.*)/i';
$str = 'www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/editradingpartnerupdates.aspx
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?gclid=jjj';
$subst = "resources/edi-tips$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;