using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(EDIResources\/EDITradingPartnerUpdates\.aspx)(.*)";
string substitution = @"resources/edi-tips$2";
string input = @"www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/editradingpartnerupdates.aspx
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?gclid=jjj";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}