# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)(EDIResources\\/EDITradingPartnerUpdates\.aspx)(.*)/resources\/edi-tips$2/ig;t' <<< "www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/editradingpartnerupdates.aspx
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?gclid=jjj"