re = /(?i)(EDIResources\/EDITradingPartnerUpdates\.aspx)(.*)/i
str = 'www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/editradingpartnerupdates.aspx
www.1edisource.com/ediresources/editradingpartnerupdates.aspx?gclid=jjj'
subst = 'resources/edi-tips$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result