import Foundation
let pattern = #"^\s*(addi|andi|ori)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*([0-9]+)\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
addi $s7,$s7,9
addi $s7,$s7,9
addi $v0,$s1,12
addi $v0,$s1,12
andi $t0,$a0,1
andi $t0,$a0,1
andi $v1,$a2,7
andi $v1,$a2,7
ori $t1,$t2,16
ori $t1,$t2,16
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)