re = /^\s*(addi|andi|ori)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*([0-9]+)\s*$/m
str = ' addi $s7,$s7,9
addi $s7,$s7,9
addi $v0,$s1,12
addi $v0,$s1,12
andi $t0,$a0,1
andi $t0,$a0,1
andi $v1,$a2,7
andi $v1,$a2,7
ori $t1,$t2,16
ori $t1,$t2,16'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end