use strict;
my $str = ' addi $s7,$s7,9
addi $s7,$s7,9
addi $v0,$s1,12
addi $v0,$s1,12
andi $t0,$a0,1
andi $t0,$a0,1
andi $v1,$a2,7
andi $v1,$a2,7
ori $t1,$t2,16
ori $t1,$t2,16';
my $regex = qr/^\s*(addi|andi|ori)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*([0-9]+)\s*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}