const regex = /^\s*(addi|andi|ori)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*([0-9]+)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(addi|andi|ori)\\s*(\\$[a-z0-9]{2,4}),\\s*(\\$[a-z0-9]{2,4}),\\s*([0-9]+)\\s*$', 'gm')
const str = ` addi \$s7,\$s7,9
addi \$s7,\$s7,9
addi \$v0,\$s1,12
addi \$v0,\$s1,12
andi \$t0,\$a0,1
andi \$t0,\$a0,1
andi \$v1,\$a2,7
andi \$v1,\$a2,7
ori \$t1,\$t2,16
ori \$t1,\$t2,16`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}