import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(addi|andi|ori)\\s*(\\$[a-z0-9]{2,4}),\\s*(\\$[a-z0-9]{2,4}),\\s*([0-9]+)\\s*$";
final String string = " addi $s7,$s7,9\n"
+ " addi $s7,$s7,9\n"
+ " addi $v0,$s1,12\n"
+ " addi $v0,$s1,12\n"
+ " andi $t0,$a0,1\n"
+ " andi $t0,$a0,1\n"
+ " andi $v1,$a2,7\n"
+ " andi $v1,$a2,7\n"
+ " ori $t1,$t2,16\n"
+ " ori $t1,$t2,16";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}