# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(addi|andi|ori)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*([0-9]+)\s*$"
test_str = (" addi $s7,$s7,9\n"
" addi $s7,$s7,9\n"
" addi $v0,$s1,12\n"
" addi $v0,$s1,12\n"
" andi $t0,$a0,1\n"
" andi $t0,$a0,1\n"
" andi $v1,$a2,7\n"
" andi $v1,$a2,7\n"
" ori $t1,$t2,16\n"
" ori $t1,$t2,16")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.