#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(addi|andi|ori)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*([0-9]+)\s*$"
Local $sString = " addi $s7,$s7,9" & @CRLF & _
" addi $s7,$s7,9" & @CRLF & _
" addi $v0,$s1,12" & @CRLF & _
" addi $v0,$s1,12" & @CRLF & _
" andi $t0,$a0,1" & @CRLF & _
" andi $t0,$a0,1" & @CRLF & _
" andi $v1,$a2,7" & @CRLF & _
" andi $v1,$a2,7" & @CRLF & _
" ori $t1,$t2,16" & @CRLF & _
" ori $t1,$t2,16"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")