using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(addi|andi|ori)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*([0-9]+)\s*$";
string input = @" addi $s7,$s7,9
addi $s7,$s7,9
addi $v0,$s1,12
addi $v0,$s1,12
andi $t0,$a0,1
andi $t0,$a0,1
andi $v1,$a2,7
andi $v1,$a2,7
ori $t1,$t2,16
ori $t1,$t2,16";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}