import Foundation
let pattern = #"([\s\[\{,:]+)(?!\-?\.?\d|false\W|true\W)([^'\":,\s\]\}]+)([:\s,\}\]_\-\{\[]|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[
{
path: '/my-profile', name: 'my_profile', component: MyProfile,
child-ren: [
{
path: 'info', name: 'my_info', component: BasicInForm,
},
{
path: 'photos', name: 'my_photos', component: MyPhot'os,
},
{
path: 'questions', name: 'my_questions', component: MyQuestions,
},
],
},
{
path: '/', name: 'register', component: RegisterFormFlow,
},
]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1'\2'\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)