# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\s\[\{,:]+)(?!\-?\.?\d|false\W|true\W)([^'\":,\s\]\}]+)([:\s,\}\]_\-\{\[]|$)/\1'\2'\3/g;t' <<< "[
{
path: '/my-profile', name: 'my_profile', component: MyProfile,
child-ren: [
{
path: 'info', name: 'my_info', component: BasicInForm,
},
{
path: 'photos', name: 'my_photos', component: MyPhot'os,
},
{
path: 'questions', name: 'my_questions', component: MyQuestions,
},
],
},
{
path: '/', name: 'register', component: RegisterFormFlow,
},
]"