#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([\s\[\{,:]+)(?!\-?\.?\d|false\W|true\W)([^'\":,\s\]\}]+)([:\s,\}\]_\-\{\[]|$)"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" path: '/my-profile', name: 'my_profile', component: MyProfile," & @CRLF & _
" child-ren: [" & @CRLF & _
" {" & @CRLF & _
" path: 'info', name: 'my_info', component: BasicInForm," & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" path: 'photos', name: 'my_photos', component: MyPhot'os," & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" path: 'questions', name: 'my_questions', component: MyQuestions," & @CRLF & _
" }," & @CRLF & _
" ]," & @CRLF & _
" }," & @CRLF & _
" " & @CRLF & _
" {" & @CRLF & _
" path: '/', name: 'register', component: RegisterFormFlow," & @CRLF & _
" }," & @CRLF & _
"]"
Local $sSubst = "\1'\2'\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)