re = /([\s\[\{,:]+)(?!\-?\.?\d|false\W|true\W)([^'\":,\s\]\}]+)([:\s,\}\]_\-\{\[]|$)/
str = '[
{
path: \'/my-profile\', name: \'my_profile\', component: MyProfile,
child-ren: [
{
path: \'info\', name: \'my_info\', component: BasicInForm,
},
{
path: \'photos\', name: \'my_photos\', component: MyPhot\'os,
},
{
path: \'questions\', name: \'my_questions\', component: MyQuestions,
},
],
},
{
path: \'/\', name: \'register\', component: RegisterFormFlow,
},
]'
subst = '\\1\'\\2\'\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result